Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL < 9.5.23, 9.6.x < 9.6.19, 10.x < 10.14, 11.x < 11.9, 12.x < 12.4 Search Path Vulnerability (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.4

CVSSv2 Vector

CVSSv2 Vector

AV:L/AC:M/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

PostgreSQL is prone to an uncontrolled search path element vulnerability in CREATE EXTENSION.

Affected Software

Affected Software

PostgreSQL versions prior to 9.5.23, 9.6.x prior to 9.6.19, 10.x prior to 10.14, 11.x prior to 11.9 and 12.x prior to 12.4.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 9.5.23, 9.6.19, 10.14, 11.9, 12.4 or later.

Common Vulnerabilities and Exposures (CVE)