Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL 9.6.x < 9.6.22, 10.x < 10.17, 11.x < 11.12, 12.x < 12.7, 13.x < 13.3 Buffer Overflow Vulnerability - Linux

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:C/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

PostgreSQL is prone to a buffer overflow vulnerability.

Insight

Insight

While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory.

Affected Software

Affected Software

PostgreSQL version 9.6.0 through 9.6.21, 10.0 through 10.16, 11.0 through 11.11, 12.0 through 12.6 and 13.0 through 13.2.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 9.6.22, 10.17, 11.12, 12.7, 13.3 or later.

Common Vulnerabilities and Exposures (CVE)