PostgreSQL Information Disclosure And Missing Authentication Vulnerabilities Aug18 (Windows)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

5.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:P/I:P/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to information disclosure and missing authentication vulnerabilities.

Insight

Insight

Multiple flaws exists due to a missing authorization on certain statements involved with 'INSERT ... ON CONFLICT DO UPDATE' .

Affected Software

Affected Software

PostgreSQL versions before 10.5, 9.6.10 and 9.5.14 on Windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 10.5 or 9.6.10 or 9.5.14 or later. Please see the references for more information.

Common Vulnerabilities and Exposures (CVE)

Get started for free to scan for vulnerabilities

Companies of all sizes use Mageni Vulnerability Scanner. Is free for 7-days then $39 monthly regardless of how many IPs, scans, deployments or users you have. Cancel at Anytime and 7-days Money-Back Guarantee. Mageni contributes 1% of your subscription to removing CO₂ from the atmosphere.

Get Started For Free
App screenshot