Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Multiple Security Bypass Vulnerability July14 (Windows)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

8 years ago

Modified

Modified

3 years ago

Summary

This host is installed with PostgreSQL and is prone to multiple security bypass vulnerabilities.

Insight

Insight

Multiple flaws are due to, - An error when handling roles can be exploited to revoke access from other role members. - Multiple errors when handling calls to PL validator functions. - Some errors when handling name lookups. - Some boundary errors when handling wide datetime input/output.

Affected Software

Affected Software

PostgreSQL version before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to version 9.3.3, 9.2.7, 9.1.12, 9.0.16 or 8.4.20, or later.