Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Multiple Vulnerabilities - Apr16 (Windows)

Information

Severity

Severity

High

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

8.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:N/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to multiple vulnerabilities.

Insight

Insight

Multiple flaws are due to, - An error in the 'brin_page_type' and 'brin_metapage_info' functions in the pageinspect extension. - PostgreSQL does not properly maintain row-security status in cached plans.

Affected Software

Affected Software

PostgreSQL version 9.5.x before 9.5.2 on windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to version 9.5.2 or higher.

Common Vulnerabilities and Exposures (CVE)