Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Multiple Vulnerabilities - August17 (Windows)

Information

Severity

Severity

High

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to multiple vulnerabilities.

Insight

Insight

Multiple flaws exist due to, - libpq, and by extension any connection driver that utilizes libpq, ignores empty passwords and does not transmit them to the server. - User had access to see the options in pg_user_mappings even if the user did not have the USAGE permission on the associated foreign server.

Affected Software

Affected Software

PostgreSQL version 9.2.x before 9.2.22, 9.3.x before 9.3.18, 9.4.x before 9.4.13, and 9.5.x before 9.5.8 and 9.6.x before 9.6.4 on Windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to version 9.2.22 or 9.3.18 or 9.4.13 or 9.5.8 or 9.6.4 or higher.

Common Vulnerabilities and Exposures (CVE)