Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Privilege Escalation Vulnerability - August17 (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:P/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

4 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to privilege escalation vulnerability.

Insight

Insight

The flaw is due to the 'lo_put' function which should require the same permissions as 'lowrite' function, but there was a missing permission check.

Affected Software

Affected Software

PostgreSQL version 9.4.x before 9.4.13, and 9.5.x before 9.5.8 and 9.6.x before 9.6.4 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to version 9.4.13 or 9.5.8 or 9.6.4 or higher.

Common Vulnerabilities and Exposures (CVE)