Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Remote Code Execution Vulnerability-Feb18 (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

4 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to remote code execution vulnerability.

Insight

Insight

The flaw exist because postgresql allow a user to modify the behavior of a query for other users in an incorrect way.

Affected Software

Affected Software

PostgreSQL version 9.3.x before 9.3.22, 9.4.x before 9.4.17, 9.5.x before 9.5.12, 9.6.x before 9.6.8 and 10.x before 10.3 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 10.3 or 9.6.8 or 9.5.12 or 9.4.17 or 9.3.22 or later.

Common Vulnerabilities and Exposures (CVE)