Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL Remote Denial Of Service Vulnerability June15 (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

7 years ago

Modified

Modified

3 years ago

Summary

This host is running PostgreSQL and is prone to remote denial of service vulnerability.

Insight

Insight

Flaw is triggered when a timeout interrupt is fired partway through the session shutdown sequence.

Affected Software

Affected Software

PostgreSQL version before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to version 9.0.20, 9.1.16, 9.2.11, 9.3.7, 9.4.2 or later.

Common Vulnerabilities and Exposures (CVE)