Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Python < 2.7.14, 3.3.x < 3.3.7, 3.4.x < 3.4.7, 3.5.x < 3.5.4, 3.6.x < 3.6.2 Expat 2.2.1 (bpo-30694) - Linux

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

'Expat' in Python is prone to multiple vulnerabilities.

Insight

Insight

The following vulnerabilities exist: - CVE-2012-0876: The XML parser (xmlparse.c) in expat computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via an XML file with many identifiers with the same value. - CVE-2016-0718: Expat allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a malformed input document, which triggers a buffer overflow. - CVE-2016-9063: An integer overflow during the parsing of XML using the Expat library. This vulnerability affects Firefox < 50. - CVE-2017-9233: XML External Entity vulnerability in libexpat 2.2.0 and earlier (Expat XML Parser Library) allows attackers to put the parser in an infinite loop using a malformed external entity definition from an external DTD.

Affected Software

Affected Software

Python prior to version 2.7.14, versions 3.3.x prior to 3.3.7, 3.4.x prior to 3.4.7, 3.5.x priot to 3.5.4 and 3.6.x prior to 3.6.2.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 2.7.14, 3.3.7, 3.4.7, 3.5.4, 3.6.2 or later.

Common Vulnerabilities and Exposures (CVE)