Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Redis Lua Debugger Vulnerability (GHSA-9mj9-xx53-qmxm)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.9

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:H/Au:S/C:C/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

11 months ago

Modified

Modified

11 months ago

Summary

Redis is prone to a vulnerability in the Lua Debugger.

Insight

Insight

When using the Redis Lua Debugger, users can send malformed requests that cause the debugger's protocol parser to read data beyond the actual buffer.

Affected Software

Affected Software

Redis version 3.2 and later.

Solution

Solution

Update to version 5.0.14, 6.0.16, 6.2.6 or later.

Common Vulnerabilities and Exposures (CVE)