Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Samba 3.0.0 <= 4.0.7 DoS Vulnerability (CVE-2013-4124)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

10 months ago

Modified

Modified

10 months ago

Summary

Samba 3.0.x to 4.0.7 are affected by a denial of service attack on authenticated or guest connections.

Insight

Insight

All current released versions of Samba are vulnerable to a denial of service on an authenticated or guest connection. A malformed packet can cause the smbd server to loop the CPU performing memory allocations and preventing any further service. A connection to a file share, or a local account is needed to exploit this problem, either authenticated or unauthenticated if guest connections are allowed. This flaw is not exploitable beyond causing the code to loop allocating memory, which may cause the machine to exceed memory limits.

Affected Software

Affected Software

Samba versions 3.0.0 through 3.5.21, 3.6.0 through 3.6.16 and 4.0.0 through 4.0.7.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 3.5.22, 3.6.17, 4.0.8 or later.

Common Vulnerabilities and Exposures (CVE)