Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Softalk Mail Server IMAP Denial of Service Vulnerability

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

4.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

15 years ago

Modified

Modified

4 years ago

Summary

The host is running Softalk Mail Server, which is prone to denial of service vulnerability.

Insight

Insight

The issue is due to inadequate boundary checks on specially crafted IMAP commands. The service can by crashed sending malicious IMAP command sequences.

Affected Software

Affected Software

Softalk Mail Server versions 8.5.1 and prior on Windows (all).

Solution

Solution

Upgrade to Softalk Mail Server version 8.6.0 or later.

Common Vulnerabilities and Exposures (CVE)