TYPO3 Multiple Vulnerabilities Nov12

Published: 2014-01-03 07:31:59
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:S/C:P/I:P/A:P

Detection Type:
Remote Banner Unreliable

Impact:
Successful exploitation will allow remote attackers to steal the victim's cookie-based authentication credentials or get sensitive information or execute SQL commands.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Multiple error exists in the application, - An error exist in history module, tree render API (TCA-Tree) and function menu API, which fails to encode user input properly. - An error exist in the application, which fails to check access while viewing history.

Recommendations:
Upgrade to TYPO3 version 4.5.21, 4.6.14, 4.7.6 or later.

Solution Type:
Vendor Patch

Summary:
This host is installed with TYPO3 and is prone to multiple vulnerabilities.

Affected Versions:
TYPO3 version 4.5.0 up to 4.5.20, 4.6.0 up to 4.6.13, 4.7.0 up to 4.7.5

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2012-6144
https://nvd.nist.gov/vuln/detail/CVE-2012-6145
https://nvd.nist.gov/vuln/detail/CVE-2012-6146
https://nvd.nist.gov/vuln/detail/CVE-2012-6147
https://nvd.nist.gov/vuln/detail/CVE-2012-6148

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/56472

References:

http://secunia.com/advisories/51217/
http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2012-005

Search
Severity
Medium
CVSS Score
6.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.