WordPress Advanced Custom Fields Plugin < 5.7.8 XSS Vulnerability

Published: 2019-09-16 14:37:06
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin Advanced Custom Fields is prone to a cross-site scripting (XSS) vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Impact:
Successful exploitation would allow an authenticated attacker to inject arbitrary HTML and JavaScript into the site.

Affected Versions:
WordPress Advanced Custom Fields through version 5.7.7.

Recommendations:
Update to version 5.7.8 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2018-20986

CVE Analysis

https://www.mageni.net/cve/CVE-2018-20986

References:

https://www2.deloitte.com/de/de/pages/risk/articles/wordpress-plugin-xss.html
https://www.advancedcustomfields.com/blog/acf-5-7-8-release/
https://wordpress.org/plugins/advanced-custom-fields/#developers

Severity
Low
CVSS Score
3.5
Published
2019-09-16
Modified
2019-09-16
Category
Web application abuses

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.