WordPress BackWPup Plugin 'wpabs' Parameter Remote PHP Code Execution Vulnerability

Published: 2011-04-01 13:39:52
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact:
Successful exploitation will let remote attackers to execute malicious PHP code to in the context of an affected site.

Affected Versions:
BackWPup Wordpress plugin version 1.6.1, Other versions may also be affected.

Technical Details:
The flaws are caused by improper validation of user-supplied input to the 'wpabs' parameter in 'wp-content/plugins/backwpup/app/wp_xml_export.php', which allows attackers to execute arbitrary PHP code in the context of an affected site. NOTE : Exploit will only work properly with the following PHP settings: register_globals=On, allow_url_include=On and magic_quotes_gpc=Off

Summary:
This host is installed with WordPress BackWPup Plugin and is prone to remote PHP code execution vulnerability.

Recommendations:
Upgrade BackWPup Wordpress plugin to 1.7.1 or later.

Detection Type:
Remote Vulnerability

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2011-4342

References:

http://www.exploit-db.com/exploits/17056/
http://seclists.org/fulldisclosure/2011/Mar/328
http://www.senseofsecurity.com.au/advisories/SOS-11-003
http://wordpress.org/extend/plugins/backwpup/

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.