WordPress Easy Forms for Mailchimp Plugin < 6.5.3 Code Injection Vulnerability

Published: 2019-09-16 13:46:25
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin Easy Forms for Mailchimp is prone to a code injection vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The vulnerability is exploitable via the admin input field.

Impact:
Successful exploitation would allow an attacker to execute arbitrary code on the target machine.

Affected Versions:
WordPress Easy Forms for Mailchimp plugin through version 6.5.2.

Recommendations:
Update to version 6.5.3 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15318

References:

https://wpvulndb.com/vulnerabilities/9583
https://wordpress.org/plugins/yikes-inc-easy-mailchimp-extender/#developers

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.