WordPress Icegram Plugin < 1.10.29 XSS Vulnerability

Published: 2019-09-05 11:30:30
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin Icegram is prone to a cross-site scripting (XSS) vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The vulnerability exists within ig_cat_list.

Impact:
Successful exploitation would allow an authenticated attacker to inject arbitrary HTML or JavaScript into the site.

Affected Versions:
WordPress Icegram plugin through version 1.10.28.2.

Recommendations:
Update to version 1.10.29 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15830

References:

https://wpvulndb.com/vulnerabilities/9440
https://blog.sucuri.net/2019/07/icegram-persistent-cross-site-scripting.html
https://wordpress.org/plugins/icegram/#developers

Severity
Low
CVSS Score
3.5
Published
2019-09-05
Modified
2019-09-05
Category
Web application abuses

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.