WordPress Is-human Plugin 'passthru()' Function Remote Command Execution Vulnerability

Published: 2011-05-26 08:47:46

CVSS Base Vector:
AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact:
Successful exploitation will let remote attackers to execute malicious commands in the context of an affected site, also remote code execution is possible.

Affected Versions:
Is-human Wordpress plugin version 1.4.2 and prior.

Technical Details:
The flaws are caused by improper validation of user-supplied input to the 'passthru()' function in 'wp-content/plugins/is-human/engine.php', which allows attackers to execute commands in the context of an affected site.

Recommendations:
No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Summary:
This host is installed with WordPress Is-human Plugin and is prone to remote command execution vulnerability.

Detection Type:
Remote Vulnerability

Solution Type:
Vendor will not fix

References:

http://xforce.iss.net/xforce/xfdb/67500
http://www.exploit-db.com/exploits/17299
http://wordpress.org/extend/plugins/is-human
http://packetstormsecurity.org/files/view/101497

Search
Severity
High
CVSS Score
10.0

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.