WordPress LoginPress Plugin < 1.1.4 Multiple Vulnerabilities

Published: 2019-09-12 11:44:18
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin LoginPress is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Following vulnerabilities exist: - There is no capabilities check for updates to settings. - There is an SQL injection vulnerability via an import of settings.

Impact:
Successful exploitation would allow an attacker to read and modify data in the database and maybe even execute arbitrary code on the target machine.

Affected Versions:
WordPress LoginPress plugin through version 1.1.3.

Recommendations:
Update to version 1.1.4 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15871
https://nvd.nist.gov/vuln/detail/CVE-2019-15872

References:

https://www.webarxsecurity.com/loginpress-plugin/
https://wordpress.org/plugins/loginpress/#developers

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.