WordPress OneSignal Plugin < 1.17.8 XSS Vulnerability

Published: 2019-09-05 10:59:43
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin OneSignal is prone to a cross-site scripting (XSS) vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The vulnerability is exploitable via the subdomain parameter.

Impact:
Successful exploitation would allow an authenticated attacker to inject arbitrary HTML and JavaScript into the site.

Affected Versions:
WordPress OneSignal plugin through version 1.17.7.

Recommendations:
Update to version 1.17.8.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15827

References:

https://www.zeroscience.mk/en/vulnerabilities/ZSL-2019-5530.php
https://wpvulndb.com/vulnerabilities/9478
https://wordpress.org/plugins/onesignal-free-web-push-notifications/#developers

Severity
Low
CVSS Score
3.5
Published
2019-09-05
Modified
2019-09-05
Category
Web application abuses

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.