WordPress OptionTree Plugin < 2.7.3 Multiple Vulnerabilities

Published: 2019-09-16 14:02:26
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin OptionTree is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Following vulnerabilities exist: - Object Injection because the + character is mishandled - Object Injection because serialized classes are mishandled

Impact:
Successful exploitation would allow an attacker to execute arbitrary code on the target machine.

Affected Versions:
WordPress OptionTree plugin through version 2.7.2.

Recommendations:
Update to version 2.7.3.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15320
https://nvd.nist.gov/vuln/detail/CVE-2019-15321

CVE Analysis

https://www.mageni.net/cve/CVE-2019-15320
https://www.mageni.net/cve/CVE-2019-15321

References:

https://wpvulndb.com/vulnerabilities/9600
https://wordpress.org/plugins/option-tree/#developers

Severity
High
CVSS Score
7.5
Published
2019-09-16
Modified
2019-09-16
Category
Web application abuses

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.