Plugins Database As of 12-14-2019

Symfony 4.2.x < 4.2.12, 4.3.x < 4.3.8 Multiple Vulnerabilities

Web application abuses
Impact by CVSS Score
  • ID: 1.3.6.1.4.1.25623.1.0.112669

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:N

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Symfony is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The following vulnerabilities exist: - The ability to enumerate users was possible without relevant permissions due to different handling depending on whether the user existed or not when attempting to use the switch users functionality. - Some strings were not properly escaped when being dumped by the VarExporter component. The VarExporter is notably used by the Symfony Cache Component PhpFilesAdapter and PhpArrayAdapter adapters.

Affected Versions:
Symfony versions 4.2.0 to 4.2.11 and 4.3.0 to 4.3.7.

Recommendations:
The issue has been fixed in Symfony 4.2.12 and 4.3.8. NOTE: No fixes are provided for Symfony 4.1 as they are not maintained anymore. It is recommended to upgrade to a supported version as soon as possible.

Search
Severity
Medium
CVSS Score
5.0
Published
2019-11-22 10:38:11
Modified
2019-11-22 10:58:15
CVE
CVE-2019-11325
CVE-2019-18886

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.