Plugins Database As of 12-11-2019

Symfony 2.8.0 <= 2.8.51, 3.4.0 <= 3.4.34, 4.2.0 <= 4.2.11 and 4.3.0 <= 4.3.7 Multiple Vulnerabilities

Web application abuses
Impact by CVSS Score
  • ID:

CVSS Base Vector:

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Symfony is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The following vulnerabilities exist: - When checking the signature of an URI (an ESI fragment URL for instance), the URISigner did not used a constant time string comparison function, resulting in a potential remote timing attack vulnerability. - Provided file paths were not being properly escaped before being used in the FileBinaryMimeTypeGuesser resulting in potential argument injection through the provided $path variable.

Affected Versions:
Symfony versions 2.8.0 to 2.8.51, 3.4.0 to 3.4.34, 4.2.0 to 4.2.11 and 4.3.0 to 4.3.7.

The issue has been fixed in Symfony 2.8.52, 3.4.35, 4.2.12 and 4.3.8. NOTE: Note that no fixes are provided for Symfony 3.0, 3.1, 3.2, 3.3, 4.0 and 4.1 as they are not maintained anymore. This will be the last Symfony 2.8 security fix as it enters EOL. Please upgrade to a more recent version of Symfony to continue receiving updates.

CVSS Score
2019-11-22 10:38:11
2019-11-22 10:58:15

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.