Summary: Apache HTTP server is prone to multiple vulnerabilities.
Technical Details: Apache HTTP server is prone to multiple vulnerabilities:
- A limited cross-site scripting issue affecting the mod_proxy error page. An attacker
could cause the link on the error page to be malformed and instead point to a page of
their choice. This would be exploitable where a server was set up with proxying enabled
but was misconfigured in such a way that the Proxy Error page was displayed. (CVE-2019-10092)
- Redirects configured with mod_rewrite that were intended to be self referential
might be fooled by encoded newlines and redirect instead to an unexpected URL within
the request URL. (CVE-2019-10098)
Detection Method: Checks if a vulnerable version is present on the target host.
Affected Versions: Apache HTTP server version 2.4.0 to 2.4.40.
Recommendations: Update to version 2.4.41 or later.
Find and Fix this Vulnerability:
Mageni can help you to find out if you have this or more vulnerabilities exposing you to hackers, ransomware and malware: Download Mageni's Free Edition