Apache HTTP Server Stack Overflow Vulnerability (Linux)

Technical Details

Severity Level:

Medium Severity

CVSS Score:

6.0

CVSS Base Vector:
AV:N/AC:M/Au:S/C:P/I:P/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Apache HTTP server is prone to a stack overflow vulnerability.

Technical Details:
When mod_remoteip was configured to use a trusted intermediary proxy server using the 'PROXY' protocol, a specially crafted PROXY header could trigger a stack buffer overflow or NULL pointer dereference. This vulnerability could only be triggered by a trusted proxy and not by untrusted HTTP clients.

Detection Method:
Checks if a vulnerable version is present on the target host.

Affected Versions:
Apache HTTP server version 2.4.32 to 2.4.39.

Recommendations:
Update to version 2.4.41 or later.

Family:

Web Servers

Creation Time:

2019-10-18 13:16:20

Modification Time:

2019-10-18 14:24:52

Find and Fix this Vulnerability:

Mageni can help you to find out if you have this or more vulnerabilities exposing you to hackers, ransomware and malware: Download Mageni's Free Edition

NVD CVE ID:
CVE-2019-10097

Don't pay for a vulnerability scanning and management platform. This one is free.

Mageni provides a free vulnerability scanning and management platform which helps you need to find, prioritize, remediate and manage your vulnerabilities.