Plugins Database As of 12-14-2019

Moodle < 3.5.9, 3.6.x < 3.6.7, 3.7.x < 3.7.3 Multiple Vulnerabilities

Web application abuses
Impact by CVSS Score
  • ID: 1.3.6.1.4.1.25623.1.0.143152

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:N

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Moodle is prone to multiple vulnerabilities.

Technical Details:
Moodle is prone to multiple vulnerabilities: - Assigned Role in Cohort did not un-assign on removal (CVE-2019-14879) - Add additional verification for some OAuth 2 logins to prevent account compromise (CVE-2019-14880) - Open redirect in Lesson edit page (CVE-2019-14882) - Reflected XSS possible from some fatal error messages (CVE-2019-14884)

Detection Method:
Checks if a vulnerable version is present on the target host.

Affected Versions:
Moodle versions prior to 3.5.9, 3.6.7 or 3.7.3.

Recommendations:
Update to version 3.5.9, 3.6.7, 3.7.3 or later.

Search
Severity
Medium
CVSS Score
6.4
Published
2019-11-20 09:11:19
Modified
2019-11-20 09:34:29
CVE
CVE-2019-14884
CVE-2019-14882
CVE-2019-14880
CVE-2019-14879

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.