Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2001-1370

CVE information

Published

21 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

prepend.php3 in PHPLib before 7.2d, when register_globals is enabled for PHP, allows remote attackers to execute arbitrary scripts via an HTTP request that modifies $_PHPLIB[libdir] to point to malicious code on another server, as seen in Horde 1.2.5 and earlier, IMP before 2.2.6, and other packages that use PHPLib..

CVSSv2.0 Score

Severity
High
Base Score
10/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:phplib_team:phplib:7.2c:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:phplib_team:phplib:7.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:phplib_team:phplib:7.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:phplib_team:phplib:7.2b:*:*:*:*:*:*:*
  Yes
- -