Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2002-0838

CVE information

Published

20 years ago

Last Modified

6 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf..

CVSSv2.0 Score

Severity
Medium
Base Score
4.6/10
Exploit Score
3.9/10
Access Vector
Local
Access Complexity
Low
Authentication Required
None
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:gv:gv:3.4.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ghostview:ghostview:1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.4.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7b4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.5.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.2.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.9.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7b1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.5.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ggv:ggv:1.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7b2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7b3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.1.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ghostview:ghostview:1.4.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.0.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:3.4.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ghostview:ghostview:1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ghostview:ghostview:1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:gv:gv:2.7b5:*:*:*:*:*:*:*
  Yes
- -