Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2003-0189

CVE information

Published

19 years ago

Last Modified

1 year ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

The authentication module for Apache 2.0.40 through 2.0.45 on Unix does not properly handle threads safely when using the crypt_r or crypt functions, which allows remote attackers to cause a denial of service (failed Basic authentication with valid usernames and passwords) when a threaded MPM is used..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:apache:http_server:2.0.42:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:http_server:2.0.44:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:http_server:2.0.41:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:http_server:2.0.45:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:http_server:2.0.40:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:http_server:2.0.43:*:*:*:*:*:*:*
  Yes
- -

References