Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2003-0222

CVE information

Published

19 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Stack-based buffer overflow in Oracle Net Services for Oracle Database Server 9i release 2 and earlier allows attackers to execute arbitrary code via a "CREATE DATABASE LINK" query containing a connect string with a long USING parameter..

CVSSv2.0 Score

Severity
High
Base Score
9/10
Exploit Score
8/10
Access Vector
Network
Access Complexity
Low
Authentication Required
Single
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:oracle:database_server:8.0.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.0x:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.1.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:7.3.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.1.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:9.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1.7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:9.2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1.7.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.1x:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.2.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.2.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle8i:8.0.6.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:7.3.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:database_server:8.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:oracle9i:9.0.1.4:*:*:*:*:*:*:*
  Yes
- -