Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2004-0980

CVE information

Published

17 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Format string vulnerability in ez-ipupdate.c for ez-ipupdate 3.0.10 through 3.0.11b8, when running in daemon mode with certain service types in use, allows remote servers to execute arbitrary code..

CVSSv2.0 Score

Severity
High
Base Score
10/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:angus_mackay:ez-ipupdate:3.0.11b5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:angus_mackay:ez-ipupdate:3.0.11b8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:arm:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:m68k:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:ia-32:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:mips:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:mipsel:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:sparc:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:ppc:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:hppa:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:ia-64:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:alpha:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:s-390:*:*:*:*:*
  Yes
- -
cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:3.0:*:*:*:*:*:*:*
  Yes
- -