CVE-2009-3631 Details

CVE-2009-3631

Published: 2009-11-02
Last Modified: 2017-08-17
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

The Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2, when the DAM extension or ftp upload is enabled, allows remote authenticated users to execute arbitrary commands via shell metacharacters in a filename.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 6.8/10
Access Vector Network
Access Complexity Medium
Authentication Single
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:M/Au:S/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:typo3:typo3:0.1.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.0.14:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.1.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.1.09:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.1.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.2.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.3.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:1.3.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.3.x:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.5.x:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.6.x:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.7.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.7.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.7.x:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:3.8.x:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.0.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.0:beta1:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.0:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.1.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.2.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:typo3:typo3:4.3:alpha1:*:*:*:*:*:* Yes - -
References

http://marc.info/?l=oss-security&m=125632856206736&w=2
http://secunia.com/advisories/37122
http://typo3.org/teams/security/security-bulletins/typo3-sa-2009-016/
http://www.securityfocus.com/bid/36801
http://www.vupen.com/english/advisories/2009/3009
https://exchange.xforce.ibmcloud.com/vulnerabilities/53923

CVE ID
CVE-2009-3631
Published
2009-11-02
Modified
2017-08-17
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-94

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.