CVE-2010-0063

CVE information

Published

12 years ago

Last Modified

12 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

Incomplete blacklist vulnerability in CoreTypes in Apple Mac OS X before 10.6.3 makes it easier for user-assisted remote attackers to execute arbitrary JavaScript via a web page that offers a download with a Content-Type value that is not on the list of possibly unsafe content types for Safari, as demonstrated by the values for the (1) .ibplugin and (2) .url extensions..

CVSSv2.0 Score

Severity
Medium
Base Score
6.8/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:apple:mac_os_x:10.5.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.6.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.6.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.6.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.6.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:10.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x_server:10.5.0:*:*:*:*:*:*:*
  Yes
- -

Get started for free to scan for vulnerabilities

Companies of all sizes use Mageni to scan their assets for vulnerabilities. Mageni is free for 7-days then $39 USD Monthly regardless of how many IPs, scans, deployments or users you have. Cancel at Anytime and 7-days Money-Back Guarantee. Developed and supported by certified CompTIA PenTest+ professionals. Mageni contributes 1% of your subscription to removing CO₂ from the atmosphere.

Get Started For Free
App screenshot