Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2010-0370

CVE information

Published

12 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

Low

Impact Analysis

Description

Cross-site scripting (XSS) vulnerability in the Node Blocks module 5.x-1.1 and earlier, and 6.x-1.3 and earlier, a module for Drupal, allows remote authenticated users, with permissions to create or edit content and administer blocks, to inject arbitrary web script or HTML via the edit-title parameter (aka block title)..

CVSSv2.0 Score

Severity
Low
Base Score
3.5/10
Exploit Score
6.8/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
Single
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
None
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:thomas_turnbull:nodeblock:*:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:thomas_turnbull:nodeblock:6.x-1.2:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:thomas_turnbull:nodeblock:6.x-1.x:dev:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:thomas_turnbull:nodeblock:6.x-1.1:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:thomas_turnbull:nodeblock:6.x-1.0:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:roger_lopez:nodeblock:*:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*
  No
-