Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2012-0213

CVE information

Published

10 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

The UnhandledDataStructure function in hwpf/model/UnhandledDataStructure.java in Apache POI 3.8 and earlier allows remote attackers to cause a denial of service (OutOfMemoryError exception and possibly JVM destabilization) via a crafted length value in a Channel Definition Format (CDF) or Compound File Binary Format (CFBF) document..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:apache:poi:2.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.7:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0.2:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.10:dev:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:pre3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0.2:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.7:dev:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.14.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0:alpha1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.8:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.13.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.7:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.8:beta5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.7:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:pre1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.8:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.11.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0:alpha2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.8:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.1:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.8:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.8:dev:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:2.0:pre2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.12.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.5:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:0.10.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.0:alpha3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:3.1:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:poi:1.0.0:*:*:*:*:*:*:*
  Yes
- -