Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2014-0080

CVE information

Published

8 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns..

CVSSv2.0 Score

Severity
Medium
Base Score
6.8/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:rubyonrails:rails:4.0.0:-:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.1:-:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.1.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.0:beta:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.1:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.1:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.1:rc3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:rubyonrails:rails:4.0.1:rc4:*:*:*:*:*:*
  Yes
- -