Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2014-4834

CVE information

Published

8 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

IBM WebSphere Commerce 6.x through 6.0.0.11 and 7.x through 7.0.0.8 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption, and application crash) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564..

CVSSv2.0 Score

Severity
Medium
Base Score
4.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:ibm:websphere_commerce:6.0.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:7.0.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ibm:websphere_commerce:6.0.0.0:*:*:*:*:*:*:*
  Yes
- -