Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2015-2348

CVE information

Published

9 years ago

Last Modified

6 months ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

The move_uploaded_file implementation in ext/standard/basic_functions.c in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 truncates a pathname upon encountering a \x00 character, which allows remote attackers to bypass intended extension restrictions and create files with unexpected names via a crafted second argument. NOTE: this vulnerability exists because of an incomplete fix for CVE-2006-7243..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
None
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:
  Yes
- -
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:redhat:enterprise_linux_hpc_node:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:redhat:enterprise_linux_hpc_node_eus:7.1:*:*:*:*:*
  Yes
- -
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:alpha5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.19:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.21:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.17:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:alpha3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.15:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:alpha2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:alpha1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.22:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.18:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:alpha2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.20:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.6.0:alpha4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.5.9:*:*:*:*:*:*:*
  Yes
- -