CVE-2018-16831 Details

CVE-2018-16831

Published: 2018-09-11
Last Modified: 2018-11-16
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 7.1/10
Exploit Score 8.6/10
Access Vector Network
Access Complexity Medium
Authentication None
Impact Score 6.9/10
Confidentiality Impact Complete
Availability Impact None
Integrity Impact None
Vector String AV:N/AC:M/Au:N/C:C/I:N/A:N
Common Vulnerability Score System v3.1
Severity Medium
Base Score 5.9/10
Exploit Score 2.2/10
Access Vector Network
Access Complexity High
Privileges Required None
Impact Score 3.6/10
Confidentiality Impact High
Availability Impact None
Integrity Impact None
Scope Unchanged
User Interaction None
Vector String CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* Yes 3.0.0 -
References

https://github.com/smarty-php/smarty/issues/486

CVE ID
CVE-2018-16831
Published
2018-09-11
Modified
2018-11-16
CVSSv2.0
High
CVSSv3.1
Medium
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-22

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.