Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Apple Mac OS X Multiple Vulnerabilities-HT207797

Information

Severity

Severity

Critical

Family

Family

Mac OS X Local Security Checks

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

3 years ago

Summary

This host is running Apple Mac OS X and is prone to multiple vulnerabilities.

Insight

Insight

Multiple flaws exists due to, - A certificate validation issue existed in EAP-TLS when a certificate changed. - Multiple memory corruption issues. - Multiple input validation issues. - A URL handling issue due to poor state management. - An issue existed within the path validation logic for symlinks. - A race condition due to poor locking mechanism. - An access issue due to poor sandbox restrictions. - A use after free issue due to poor state management. - A buffer overflow issue due to poor memory handling.

Affected Software

Affected Software

Apple Mac OS X version 10.12.x before 10.12.5

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to Apple Mac OS X version 10.12.5 or later.