Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Asterisk DoS Vulnerability (AST-2021-002)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

Asterisk is prone to a denial of service vulnerability when negotiating T.38.

Insight

Insight

When re-negotiating for T.38 if the initial remote response was delayed just enough Asterisk would send both audio and T.38 in the SDP. If this happened, and the remote responded with a declined T.38 stream then Asterisk would crash.

Affected Software

Affected Software

Asterisk Open Source 16.15.0 - 16.16.0, 17.9.0 - 17.9.1, 18.1.0 - 18.2.0 and 16.8-cert4 - 16.8-cert5.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 16.16.1, 17.9.2, 18.2.1, 16.8-cert6 or later.

Common Vulnerabilities and Exposures (CVE)