Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian LTS: Security Advisory for opensc (DLA-2832-1)

Information

Severity

Severity

Medium

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

4.4

CVSSv2 Vector

CVSSv2 Vector

AV:L/AC:M/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

The remote host is missing an update for the 'opensc' package(s) announced via the DLA-2832-1 advisory.

Insight

Insight

Several vulnerabilities were fixed in the OpenSC smart card utilities. CVE-2019-15945 Out-of-bounds access of an ASN.1 Bitstring. CVE-2019-15946 Out-of-bounds access of an ASN.1 Octet string. CVE-2019-19479 Incorrect read operation in the Setec driver. CVE-2020-26570 Heap-based buffer overflow in the Oberthur driver. CVE-2020-26571 Stack-based buffer overflow in the GPK driver. CVE-2020-26572 Stack-based buffer overflow in the TCOS driver.

Affected Software

Affected Software

'opensc' package(s) on Debian Linux.

Detection Method

Detection Method

Checks if a vulnerable package version is present on the target host.

Solution

Solution

For Debian 9 stretch, these problems have been fixed in version 0.16.0-3+deb9u2. We recommend that you upgrade your opensc packages.