Debian Security Advisory DSA 2693-1 (libx11 - several vulnerabilities)

Published: 2013-05-23 22:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Affected Versions:
libx11 on Debian Linux

Recommendations:
For the oldstable distribution (squeeze), these problems have been fixed in version 2:1.3.3-4+squeeze1. For the stable distribution (wheezy), these problems have been fixed in version 2:1.5.0-1+deb7u1. For the unstable distribution (sid), these problems have been fixed in version 2:1.5.0-1+deb7u1. We recommend that you upgrade your libx11 Linux Distribution Packages.

Summary:
Ilja van Sprundel of IOActive discovered several security issues in multiple components of the X.org graphics stack and the related libraries: Various integer overflows, sign handling errors in integer conversions, buffer overflows, memory corruption and missing input sanitising may lead to privilege escalation or denial of service.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

Detection Type:
Linux Distribution Package

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2013-2004
https://nvd.nist.gov/vuln/detail/CVE-2013-1981
https://nvd.nist.gov/vuln/detail/CVE-2013-1997

References:

http://www.debian.org/security/2013/dsa-2693.html

Search
Severity
Medium
CVSS Score
6.8

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.