Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 996-1 (libcrypt-cbc-perl)

Information

Severity

Severity

Low

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

2.6

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:H/Au:N/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

14 years ago

Modified

Modified

5 years ago

Summary

The remote host is missing an update to libcrypt-cbc-perl announced via advisory DSA 996-1. Lincoln Stein discovered that the Perl Crypt::CBC module produces weak ciphertext when used with block encryption algorithms with blocksize > 8 bytes. The old stable distribution (woody) does not contain a Crypt::CBC module.

Solution

Solution

For the stable distribution (sarge) this problem has been fixed in version 2.12-1sarge1. For the unstable distribution (sid) this problem has been fixed in version 2.17-1. We recommend that you upgrade your libcrypt-cbc-perl package. https://secure1.securityspace.com/smysecure/catid.html?in=DSA%20996-1

Common Vulnerabilities and Exposures (CVE)