Discourse < 2.4.0.beta9 Multiple Vulnerabilities

Published: 2020-03-19 09:04:27

CVSS Base Vector:
AV:N/AC:M/Au:N/C:P/I:N/A:N

Summary:
Discourse is prone to multiple vulnerabilities.

Technical Details:
The following flaws exist / security fixes are included: - Correct permission check when revoking user API keys - Vulnerability in WildcardUrlChecker - Upgrade rack-mini-profiler to avoid possible XSS - Remove event handlers from SVG files - Ensure only image uploads can be inlined - Bump puma from 3.12.1 to 3.12.2

Affected Versions:
Discourse up to and including version 2.4.0.beta8.

Recommendations:
Update to version 2.4.0.beta9 or later.

Detection Method:
Checks if a vulnerable version is present on the target host.

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

References:

https://meta.discourse.org/t/discourse-2-4-0-beta9-release-notes/136517

Search
Severity
Medium
CVSS Score
4.3

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.