Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Dnsmasq < 2.76 DoS Vulnerability

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

Dnsmasq is prone to an improper bounds checking vulnerability which may lead to a denial of service condition.

Insight

Insight

An attacker controlled DNS server may send large DNS packets that result in a read operation beyond the buffer allocated for the packet.

Affected Software

Affected Software

Dnsmasq versions prior to 2.76.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 2.76 or later.

Common Vulnerabilities and Exposures (CVE)