Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Dnsmasq <= 2.86 Multiple Vulnerabilities

Information

Severity

Severity

High

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

None Solution Available

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

Dnsmasq is prone to multiple vulnerabilities.

Insight

Insight

The following flaws exist: - CVE-2021-45951: Heap-based buffer overflow in check_bad_address - CVE-2021-45952: Heap-based buffer overflow in dhcp_reply - CVE-2021-45953: Heap-based buffer overflow in extract_name - CVE-2021-45954: Heap-based buffer overflow in extract_name - CVE-2021-45955: Heap-based buffer overflow in resize_packet - CVE-2021-45956: Heap-based buffer overflow in print_mac - CVE-2021-45957: Heap-based buffer overflow in answer_request

Affected Software

Affected Software

Dnsmasq version 2.86 and prior.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

No known solution is available as of 11th January, 2022. Information regarding this issue will be updated once solution details are available.