Drupal Cross Site Scripting Vulnerability (SA-CORE-2018-003) (Linux)

Published: 2018-04-19 08:39:14
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:M/Au:N/C:N/I:P/A:N

Detection Type:
Remote Banner Unreliable

Summary:
This host is running Drupal and is prone to a cross-site scripting vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The flaw exists in 'CKEditor' used within the 'Enhanced Image (image2)' plugin, Which allows attackers to execute XSS inside CKEditor using the '' tag and specially crafted HTML.

Impact:
Successful exploitation will allow remote attackers to execute a script on victim's Web browser within the security context of the hosting Web site.

Affected Versions:
Drupal core versions 8.x before 8.4.7 and Drupal core versions 8.5.0 before 8.5.2 on Linux.

Recommendations:
Upgrade to Drupal core version 8.4.7, 8.5.2 or later. Please see the references for more information.

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2018-9861

References:

https://www.drupal.org/sa-core-2018-003
https://www.drupal.org/project/drupal

Search
Severity
Medium
CVSS Score
4.3

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.