Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

ImageMagick Buffer Overflow Vulnerability (Windows)

Information

Severity

Severity

Critical

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

13 years ago

Modified

Modified

3 years ago

Summary

The host is installed with ImageMagick and is prone to Buffer Overflow Vulnerability.

Insight

Insight

The flaw occurs due to an integer overflow error within the 'XMakeImage()' function in magick/xwindow.c file while processing malformed TIFF files.

Affected Software

Affected Software

ImageMagick version prior to 6.5.2-9 on Windows.

Solution

Solution

Upgrade to ImageMagick version 6.5.2-9 or later.

Common Vulnerabilities and Exposures (CVE)